Note: Version v201902 will be sunset soon. All users of those versions must migrate to a newer one.

enum MetadataMergeSpecError.Reason (v201905)

The reason of the error.


Namespace
https://www.google.com/apis/ads/publisher/v201905
Enumeration Description
INPUT_ID_ALREADY_USED The merge rule has an input id that is already used by another merge rule.
BOUND_SPECIFIED_WITHOUT_VALUE The merge rule has an bucket where a bound type was specified without a min/max.
VALUE_SPECIFIED_WITHOUT_BOUND The merge rule has an bucket where a min/max was specified without a bound type.
MIN_EXCEEDS_MAX The merge rule has an bucket range where the min exceeds the max.
MORE_THAN_ONE_INPUT_KEY_HAS_VALUE_RULES Tried to merge two or more rules which have value rules.
VALUE_SPECIFIED_DOES_NOT_MATCH_OUTPUT_KEY Tried to set a rule for a value that does not match rule output namespace.
CANNOT_MERGE_VALUES_WHERE_VALUE_BUCKET_EXISTS Tried to merge values on an existing rule that has value bucketing.
CANNOT_MODIFY_RESERVED_KEY Tried to create a rule that depends on a reserved key.
UNKNOWN The value returned if the actual value is not exposed by the requested API version.