আপনার রেজিস্ট্রেশন সংক্রান্ত সমস্যার সমাধান করা

আপনার কানেক্ট করা অ্যাপ রেজিস্টার বা কনফিগার করার সময় কোনও সমস্যা হলে, সাধারণ সমস্যার মেসেজ, কারণ ও সমস্যা সমাধানের ধাপের নিম্নলিখিত সারণী দেখুন।

সমস্যা ত্রুটি বার্তা কারণ সমাধান / সমস্যার সমাধান করার ধাপ

"ফেচ টুল" কাজ না করার কারণ নির্দিষ্ট করা নেই

"MCP সার্ভারের বিবরণ ফেচ করা যায়নি। আবার চেষ্টা করুন।" (অথবা কোনও নির্দিষ্ট ত্রুটি মেসেজ ছাড়াই টুল নিয়ে আসুন বোতাম কাজ না করলে)।

ভুল URL, অফলাইন সার্ভার বা নেটওয়ার্কের সমস্যার কারণে Connected Console আপনার MCP এন্ডপয়েন্টে অনুরোধ সম্পূর্ণ করতে পারেনি।

নিম্নলিখিত বিষয়গুলি যাচাই করুন:

  • আপনার MCP এন্ডপয়েন্ট URL সঠিক কিনা এবং https:// ব্যবহার করে কিনা তা ডবল-চেক করুন।
  • আপনার MCP সার্ভার চলছে কিনা তা নিশ্চিত করুন।
  • আপনার MCP সার্ভার সর্বজনীন ইন্টারনেট থেকে অ্যাক্সেস করা যায় কিনা তা কনফার্ম করুন (Google localhost বা ব্যক্তিগত ইন্ট্রানেট অ্যাড্রেসে পৌঁছাতে পারে না)।

MCP সার্ভার উপলভ্য নেই

"MCP সার্ভার উপলভ্য নেই"

Google-এর ব্যাকএন্ড আপনার MCP এন্ডপয়েন্টের সাথে কানেকশন তৈরি করতে পারেনি।

সাধারণ কারণ ও সমাধানের মধ্যে এগুলি পড়ে:

  • ফায়ারওয়াল সংক্রান্ত বিধিনিষেধ: আপনার ফায়ারওয়াল বা WAF যাতে Google-এর আউটবাউন্ড IP রেঞ্জ ব্লক না করে তা নিশ্চিত করুন।
  • API গেটওয়ে সংক্রান্ত নিয়ম: আপনার API গেটওয়ে POST অনুরোধ গ্রহণ করে এবং MCP initialize হ্যান্ডশেক চলাকালীন Google-এর clientInfo প্রত্যাখ্যান করে না তা যাচাই করুন।
  • সাবডোমেন মিলছে না: আপনি কোনও নির্দিষ্ট সাবডোমেন (যেমন gemini.mcp.company.com) ব্যবহার করলে, নিশ্চিত করুন যে এটির /.well-known/oauth-protected-resource মেটাডেটা অন্য কোনও বেস ডোমেন (mcp.company.com) দেখানোর পরিবর্তে সেই সাবডোমেনের সাথে মিলছে।

অসমর্থিত MCP ট্রান্সপোর্ট (HTTP 405)

"MCP সার্ভার অনুরোধ বাতিল করেছে (HTTP 405 পদ্ধতি অনুমোদিত নয়)। নিশ্চিত করুন যে URLটি একটি স্ট্রিমেবল HTTP এন্ডপয়েন্টকে নির্দেশ করে যা POST অনুরোধ গ্রহণ করে, কোনও লিগ্যাসি SSE এন্ডপয়েন্ট নয়।"

এন্ডপয়েন্ট URL একটি পুরনো HTTP+SSE এন্ডপয়েন্টকে নির্দেশ করে যা শুধুমাত্র GET অনুরোধ গ্রহণ করে বা JSON-RPC POST অনুরোধ প্রত্যাখ্যান করে।

MCP স্ট্রিমেবল HTTP ট্রান্সপোর্ট ব্যবহার করতে আপনার MCP সার্ভার এবং এন্ডপয়েন্ট URL আপডেট করুন যা initialize এবং tools/list-এর জন্য POST অনুরোধ গ্রহণ করে।

OAuth সুরক্ষিত রিসোর্স ফাইল নেই

"MCP সার্ভারে /.well-known/oauth-protected-resource ফাইলটি নেই"

Google, OAuth 2.0 সুরক্ষিত রিসোর্স মেটাডেটা ডিসকভারি (RFC 9728) করার চেষ্টা করেছে, যা ব্যর্থ হয়েছে।

  • আপনার MCP সার্ভারে যাচাইকরণের প্রয়োজন না হলে: সাধারণত এই সমস্যা তখন হয় যখন MCP এন্ডপয়েন্ট URL-এ টাইপো থাকে বা পাথ সেগমেন্ট মিসিং থাকে (যেমন, https://mcp.example.com/mcp-এর পরিবর্তে https://mcp.example.com) এবং HTTP 404 বা 500 রিটার্ন করে, যার ফলে ক্লায়েন্ট OAuth ডিসকভারিতে ফলব্যাক করে। যাচাই করুন যে আপনার সঠিক MCP এন্ডপয়েন্ট পাথ যাচাই না করা POST initialize এবং tools/list অনুরোধের জন্য HTTP 200 OK রিটার্ন করে এবং অ্যাক্সেস ক্রেডেনশিয়াল-এর মধ্যে আপনার সার্ভারের কি অনুমোদন প্রয়োজন? বিকল্পের অধীনে না বেছে নিন।
  • আপনার MCP সার্ভারে যাচাইকরণ প্রয়োজন হলে: আপনার MCP সার্ভারে একটি সঠিক /.well-known/oauth-protected-resource JSON ফাইল হোস্ট করুন যা authorization_servers অ্যারেতে আপনার বিশ্বস্ত অনুমোদন সার্ভারের বিজ্ঞাপন দেয়।

OAuth অথরাইজেশন সার্ভার মেটাডেটা নেই বা ভুল আছে

"OAuth সার্ভারে /.well-known/oauth-authorization-server ফাইলটি নেই" অথবা "এতে ভুল বা অসম্পূর্ণ JSON আছে"

আপনার OAuth সার্ভার /.well-known/oauth-authorization-server-এ সঠিক RFC 8414 মেটাডেটা ডকুমেন্ট প্রকাশ করে না।

  • /.well-known/oauth-authorization-server (বা /.well-known/openid-configuration)-এ একটি সঠিক RFC 8414 ডিসকভারি ডকুমেন্ট হোস্ট করুন যাতে authorization_endpoint এবং token_endpoint থাকে।
  • অথবা, ক্রেডেনশিয়াল বিভাগে, আপনার কাস্টম অথরাইজেশন এন্ডপয়েন্ট এবং কাস্টম টোকেন এন্ডপয়েন্ট URL ম্যানুয়ালি লিখুন।

ডোমেন যাচাই করা যায়নি

ডোমেন সার্টিফিকেট-এ "যাচাই করা যায়নি" বা "যাচাইকরণ করা যায়নি" মেসেজ সহ টুলটিপ মেসেজ (যেমন HTTP 404, রিডাইরেক্ট করার অনুমতি নেই বা টোকেন মিলছে না) দেখানো হয়।

Google https://<domain>/.well-known/google-connected-apps-এ আপনার চ্যালেঞ্জ টোকেন যাচাই করতে পারেনি।

  • ফাইল খুঁজে পাওয়া যায়নি (HTTP 404): ডাউনলোড করা google-connected-apps.json কন্টেন্ট https://<domain>/.well-known/google-connected-apps-এ (URL পাথে .json এক্সটেনশন ছাড়া) প্রকাশ করা হয়েছে কিনা তা নিশ্চিত করুন।
  • রিডাইরেক্ট করার অনুমতি নেই: যাচাইকরণ পেলোড সরাসরি HTTP 200 OK-এর মাধ্যমে পরিবেশন করুন; অন্য URL-এ /.well-known/google-connected-apps রিডাইরেক্ট করবেন না।
  • টোকেন মিলছে না: JSON উত্তরে আপনার ডেভেলপার অ্যাকাউন্টের জন্য তৈরি করা সঠিক টোকেন সহ "verification_tokens": ["<YOUR_TOKEN>"] আছে কিনা তা কনফার্ম করুন।

Dynamic Client Registration (DCR) বা CIMD ব্যর্থ হয়েছে

"Dynamic Client Registration (RFC 7591) করা যায়নি", "OAuth সার্ভারে Dynamic Client Registration (RFC 7591) কাজ করে না" অথবা "Client ID Metadata Document (CIMD) রেজিস্ট্রেশন করা যায়নি"

অটোমেটিক OAuth ক্লায়েন্ট রেজিস্ট্রেশন করা যায়নি বা আপনার OAuth প্রোভাইডার এটি সাপোর্ট করে না অথবা Google-এর রিডাইরেক্ট URI বাতিল করা হয়েছে।

  • আপনার OAuth সার্ভার যাতে সার্ভার অথেনটিকেশন ক্রেডেনশিয়াল (https://oauth-redirect.googleusercontent.com/r/<app-id>-<sanitized-domain>, ইত্যাদি) বিকল্পের অধীনে দেখানো, অ্যাপ-নির্দিষ্ট সবকটি Google রিডাইরেক্ট URI-কে অনুমতি দেয় তা নিশ্চিত করুন। মনে রাখবেন যে অনেক OAuth 2.1 সার্ভার ওয়াইল্ডকার্ড (*) রিডাইরেক্ট URI বাতিল করে দেয়।
  • আপনার OAuth পরিষেবা প্রদানকারী CIMD বা RFC 7591 DCR সমর্থন না করলে, অ্যাক্সেস ক্রেডেনশিয়াল-এ প্রি-রেজিস্টার করা (ব্যবহারকারী-প্রতিনিধি OAuth-এর জন্য) বা মেশিন-টু-মেশিন (OAuth ক্লায়েন্ট ক্রেডেনশিয়াল) বেছে নিন এবং একটি স্ট্যাটিক ক্লায়েন্ট আইডি ও ক্লায়েন্ট সিক্রেট প্রদান করুন।

OAuth লগ-ইন পপ-আপ ব্লক করা হয়েছে বা ফাঁকা আছে

"আপনার ব্রাউজার যাচাইকরণ পপ-আপ ব্লক করেছে" অথবা টুল সিঙ্ক বা পরীক্ষা করার সময় OAuth লগ-ইন উইন্ডো সঠিকভাবে দেখানো যায়নি।

আপনার লগ-ইন পৃষ্ঠায় ব্রাউজার পপ-আপ ব্লকার বা কঠোর X-Frame-Options / Content-Security-Policy হেডার পপ-আপ ফ্লোকে বাধা দিয়েছে।

  • আপনার ব্রাউজারে কনসোলের জন্য পপ-আপ দেখানোর অনুমতি দিন এবং আবার চেষ্টা করুন।
  • আপনার ডেভেলপার ক্রেডেনশিয়াল দিয়ে যাচাই করুন বিকল্পের অধীনে ক্রেডেনশিয়াল অ্যাক্সেস করুন বিকল্পে গিয়ে, পপ-আপের মাধ্যমে যাচাই করুন থেকে রিডাইরেক্টের (ফলব্যাক) মাধ্যমে যাচাই করুন বিকল্পে পরিবর্তন করুন যাতে যাচাইকরণের ফ্লো একই ট্যাবে ফুল-স্ক্রিনে খোলে।

MCP সার্ভারের নির্দেশাবলী নেই

সতর্কতামূলক মেসেজ: "আপনার MCP সার্ভারে কোনও নির্দেশাবলী নেই। আপনার সার্ভার স্কিমায় নির্দেশাবলী যোগ করলে ভালো হয়।"

আপনার MCP সার্ভার তার initialize উত্তরে কোনও instructions ফিল্ড ফেরত দেয়নি।

  • আপনার MCP সার্ভার শুরু করার সময় সিস্টেম নির্দেশাবলী স্পষ্টভাবে সংজ্ঞায়িত করুন (আপনার সার্ভার সংজ্ঞায় instructions প্যারামিটার)।
  • স্টেটলেস বা কাস্টম HTTP ইমপ্লিমেন্টেশনের জন্য, initialize পদ্ধতির জন্য JSON-RPC রেসপন্স পেলোডে instructions ফিল্ড অন্তর্ভুক্ত করা হয়েছে কিনা তা নিশ্চিত করুন, তারপর টুল আবার সিঙ্ক করুন বিকল্প বেছে নিন।

UI রিসোর্সের সাইজের সীমা বা কাজ করে না এমন MIME-এর ধরন

ফেচ করার সময় সমস্যা সংক্রান্ত সমস্যার কার্ড: "রিসোর্সের মোট সাইজ ১০০ এমবির বেশি হতে পারবে না।" অথবা "'<uri>' রিসোর্সের জন্য '<type>' MIME-এর প্রকার কাজ করে না।"

আপনার MCP সার্ভার এমন UI রিসোর্স ফিরিয়ে দিয়েছে যার মোট সাইজ সীমা অতিক্রম করেছে অথবা যা কাজ করে না এমন MIME-এর প্রকার ব্যবহার করে।

  • আপনার সার্ভার থেকে ফেরত আসা সমস্ত ম্যানিফেস্ট UI রিসোর্সের মোট সাইজ কমান যাতে এটি সীমা অতিক্রম না করে।
  • সব UI রিসোর্স যাতে কাজ করে এমন MIME প্রকারের মধ্যে কোনও একটি ব্যবহার করে তা নিশ্চিত করুন: text/html, text/html;profile=mcp-app, text/javascript অথবা text/css।

আইকন আপলোড আটকে গেছে বা "অপ্রত্যাশিত সমস্যা"

অ্যাপের বিবরণ বিভাগে অ্যাপ আইকন আপলোড করার সময়, আপলোড করার প্রসেস লোডিং স্পিনারে ফ্রিজ হয়ে যায় অথবা "অপ্রত্যাশিত সমস্যা হয়েছে। আবার চেষ্টা করুন" (প্রায়ই 4E696748 কোড সহ)।

সাধারণত ব্রাউজার সেশন পুরনো হয়ে গেলে, ব্রাউজার এক্সটেনশনের মধ্যে বিরোধ হলে অথবা যাচাইকরণের অবস্থা ক্যাশে করা থাকলে এটি হয়।

ক্রমানুসারে নিম্নলিখিত ধাপগুলি অনুসরণ করে দেখুন:

  1. নতুন ব্রাউজার প্রোফাইল ব্যবহার করুন: নতুন ব্রাউজার প্রোফাইল ব্যবহার করে নতুন উইন্ডো খুলুন।
  2. ছদ্মবেশী / ব্যক্তিগত মোড ব্যবহার করুন: ব্যক্তিগত ব্রাউজিং উইন্ডোতে Google Connected Console-এ সাইন-ইন করুন এবং আইকন আপলোড করুন।
  3. ক্যাশে মুছুন: আবার চেষ্টা করার আগে আপনার ব্রাউজারের ক্যাশে ও কুকি মুছুন এবং আপনার আইকনটি ১ এমবির কম সাইজের ৫১২ পিক্সেল × ৫১২ পিক্সেল PNG বা JPEG কিনা তা যাচাই করুন।