| Problema |
Mensagem de erro |
Causa |
Etapas de correção / solução de problemas |
Falha não especificada em "Buscar ferramentas" |
"Falha ao buscar detalhes do servidor MCP. Tente novamente." (ou o botão Buscar ferramentas falha sem uma mensagem de erro específica). |
O Connected Console não conseguiu concluir a solicitação para o endpoint do MCP devido a um URL inválido, servidor off-line ou erro de rede. |
Confirme o seguinte:
- Verifique se o URL do endpoint do MCP está correto e usa
https://.
- Verifique se o servidor MCP está em execução.
- Confirme se o servidor MCP pode ser acessado pela Internet pública (o Google não consegue acessar
localhost ou endereços de intranet privada).
|
O servidor MCP está inacessível |
"O servidor MCP está inacessível" |
O back-end do Google não conseguiu estabelecer uma conexão com seu endpoint do MCP. |
As causas e correções comuns incluem:
- Restrições de firewall: verifique se o firewall ou o WAF não bloqueia os intervalos de IP de saída do Google.
- Regras do gateway de API: verifique se o gateway de API aceita solicitações
POST e não rejeita o clientInfo do Google durante o handshake initialize do MCP.
- Incompatibilidade de subdomínio: se você usa um subdomínio dedicado (como
gemini.mcp.company.com), verifique se os metadados /.well-known/oauth-protected-resource correspondem a esse subdomínio, em vez de apontar para um domínio base diferente (mcp.company.com).
|
Transporte MCP não compatível (HTTP 405) |
"O servidor MCP rejeitou a solicitação (HTTP 405 Method Not Allowed). Verifique se o URL aponta para um endpoint HTTP que aceita solicitações POST, não para um endpoint SSE legado." |
O URL do endpoint aponta para um endpoint HTTP+SSE legado que aceita apenas solicitações GET ou rejeita solicitações JSON-RPC POST. |
Atualize o servidor MCP e o URL do endpoint para usar o transporte HTTP transmissível do MCP, que aceita solicitações POST para initialize e tools/list.
|
Arquivo de recurso protegido do OAuth ausente |
"O arquivo /.well-known/oauth-protected-resource não existe no servidor MCP" |
O Google tentou descobrir os metadados de recursos protegidos do OAuth 2.0 (RFC 9728), mas falhou. |
- Se o servidor MCP NÃO exigir autenticação: esse erro geralmente ocorre quando o URL do endpoint do MCP tem um erro de digitação ou um segmento de caminho ausente (por exemplo,
https://mcp.example.com em vez de https://mcp.example.com/mcp) e retorna HTTP 404 ou 500, fazendo com que o cliente use a descoberta do OAuth. Verifique se o caminho exato do endpoint do MCP retorna HTTP 200 OK para solicitações POST, initialize e tools/list não autenticadas e selecione Não em Seu servidor exige autorização? em Credenciais de acesso.
- Se o servidor MCP exigir autenticação: hospede um arquivo JSON
/.well-known/oauth-protected-resource válido no servidor MCP que anuncie os servidores de autorização confiáveis na matriz authorization_servers.
|
Metadados do servidor de autorização OAuth ausentes ou inválidos |
"O arquivo /.well-known/oauth-authorization-server não existe no servidor OAuth" ou "contém um JSON inválido ou incompleto" |
Seu servidor OAuth não expõe um documento de metadados RFC 8414 válido em /.well-known/oauth-authorization-server. |
- Hospede um documento de descoberta RFC 8414 válido em
/.well-known/oauth-authorization-server (ou /.well-known/openid-configuration) que contenha authorization_endpoint e token_endpoint.
- Como alternativa, na seção Credenciais, insira manualmente os URLs do Endpoint de autorização personalizado e do Endpoint de token personalizado.
|
Falha na verificação do domínio |
O certificado de domínio mostra Falha ao verificar ou Falha na verificação com uma mensagem de dica (como HTTP 404, redirecionamento não permitido ou incompatibilidade de token). |
O Google não conseguiu verificar seu token de desafio em https://<domain>/.well-known/google-connected-apps. |
- Arquivo não encontrado (HTTP 404): verifique se o conteúdo de
google-connected-apps.json que foi baixado está publicado em https://<domain>/.well-known/google-connected-apps (sem uma extensão .json no caminho do URL).
- Redirecionamentos não permitidos: veicule o payload de verificação diretamente com
HTTP 200 OK. Não redirecione /.well-known/google-connected-apps para outro URL.
- Incompatibilidade de token: confirme se a resposta JSON contém
"verification_tokens": ["<YOUR_TOKEN>"] com o token exato gerado para sua conta de desenvolvedor.
|
Falha no Registro Dinâmico de Clientes (DCR) ou no CIMD |
"Falha no registro dinâmico de clientes (RFC 7591)", "O servidor OAuth não é compatível com o registro dinâmico de clientes (RFC 7591)" ou "Falha no registro do documento de metadados de ID do cliente (CIMD)" |
O registro automático do cliente OAuth falhou ou não é compatível com seu provedor OAuth, ou os URIs de redirecionamento do Google foram rejeitados. |
- Verifique se o servidor OAuth permite todos os seis URIs de redirecionamento do Google específicos do app mostrados em Credenciais de autenticação do servidor (
https://oauth-redirect.googleusercontent.com/r/<app-id>-<sanitized-domain> etc.). Muitos servidores OAuth 2.1 rejeitam URIs de redirecionamento com caracteres curinga (*).
- Se o provedor OAuth não for compatível com CIMD ou RFC 7591 DCR, selecione Pré-registrado (para OAuth delegado pelo usuário) ou Máquina para máquina (credenciais do cliente OAuth) em Credenciais de acesso e forneça um ID do cliente e uma chave secreta do cliente estáticos.
|
O pop-up de login do OAuth está bloqueado ou em branco |
"O pop-up de autenticação foi bloqueado pelo navegador" ou a janela de login do OAuth não é exibida corretamente durante a sincronização ou o teste da ferramenta. |
Os bloqueadores de pop-up do navegador ou os cabeçalhos X-Frame-Options / Content-Security-Policy restritos na página de login impediram o fluxo de pop-up. |
- Permita pop-ups para o console no navegador e tente de novo.
- Em Credenciais de acesso, em Autenticar com suas credenciais de desenvolvedor, mude de Autenticar por pop-up para Autenticar por redirecionamento (alternativa) para que o fluxo de autenticação seja aberto em tela cheia na mesma guia.
|
Instruções do servidor MCP ausentes |
Mensagem de aviso: "Seu servidor MCP não tem instruções. Recomendamos adicionar instruções ao esquema do servidor." |
Seu servidor MCP não retornou um campo instructions na resposta initialize. |
- Defina explicitamente as instruções do sistema ao inicializar o servidor MCP (parâmetro
instructions na definição do servidor).
- Para implementações HTTP sem estado ou personalizadas, verifique se o campo
instructions está incluído no payload de resposta JSON-RPC para o método initialize e selecione Ferramentas de ressincronização.
|
Limite de tamanho do recurso da interface ou tipo MIME não aceito |
Card de erro Problemas com a busca: "O tamanho cumulativo do recurso não pode exceder 100 MB" ou "Tipo MIME '<type>' não compatível com o recurso '<uri>'". |
Seu servidor MCP retornou recursos de interface com um tamanho total que excede o limite ou que usam um tipo MIME não aceito. |
- Reduza o tamanho cumulativo de todos os recursos de IU do manifesto retornados pelo servidor para que ele não exceda o limite.
- Verifique se todos os recursos de interface usam um dos tipos MIME compatíveis:
text/html, text/html;profile=mcp-app, text/javascript ou text/css.
|
O upload do ícone travou ou ocorreu um "Erro inesperado" |
Ao fazer upload de um ícone do app em Detalhes do app, o upload congela em um ícone de carregamento ou mostra a mensagem "Ocorreu um erro inesperado. Tente novamente" (geralmente com o código 4E696748). |
Normalmente, isso é causado por uma sessão desatualizada do navegador, extensões conflitantes ou estado de autenticação em cache. |
Siga estas etapas em ordem:
- Use um perfil de navegador novo: abra uma nova janela usando um perfil de navegador limpo.
- Use o modo de navegação anônima / particular: faça login no Google Connected Console em uma janela de navegação anônima e faça upload do ícone.
- Limpe o cache: limpe o cache e os cookies do navegador antes de tentar novamente e verifique se o ícone é um PNG ou JPEG válido de 512 × 512 px com menos de 1 MB.
|