| Проблема |
Сообщение об ошибке |
Причина |
Как устранить неполадки |
Неизвестная ошибка при использовании инструментов извлечения |
"Не удалось извлечь данные MCP-сервера. Повторите попытку." (или кнопка Получить инструменты не работает, но сообщение об ошибке не появляется). |
Connected Console не удалось выполнить запрос к конечной точке MCP из-за недействительного URL, отключенного сервера или ошибки сети. |
Проверьте следующее:
- Убедитесь, что URL конечной точки MCP-сервера указан правильно и использует
https://.
- Убедитесь, что MCP-сервер работает.
- Убедитесь, что ваш MCP-сервер доступен из общедоступного интернета (Google не может подключиться к
localhost или частным адресам интранета).
|
MCP-сервер недоступен |
"MCP-сервер недоступен" |
Серверной части Google не удалось установить подключение к конечной точке MCP. |
Ниже приведены распространенные причины и способы устранения неполадок.
- Ограничения брандмауэра. Убедитесь, что ваш брандмауэр или WAF не блокирует исходящие IP-адреса Google.
- Правила шлюза API. Убедитесь, что шлюз API принимает запросы
POST и не отклоняет запросы clientInfo от Google во время рукопожатия initialize MCP.
- Несоответствие субдомена. Если вы используете выделенный субдомен (например,
gemini.mcp.company.com), убедитесь, что его метаданные /.well-known/oauth-protected-resource соответствуют этому субдомену, а не указывают на другой базовый домен (mcp.company.com).
|
Неподдерживаемый транспорт MCP (HTTP 405) |
"MCP-сервер отклонил запрос (ошибка HTTP 405: метод запрещен). Убедитесь, что URL указывает на конечную точку Streamable HTTP, которая принимает запросы POST, а не на устаревшую конечную точку SSE. |
URL конечной точки указывает на устаревшую конечную точку HTTP+SSE, которая принимает только запросы GET или отклоняет запросы JSON-RPC POST. |
Обновите MCP-сервер и URL конечной точки, чтобы использовать транспорт Streamable HTTP для MCP, который принимает запросы POST для initialize и tools/list.
|
Отсутствует файл защищенного ресурса OAuth |
"Файл /.well-known/oauth-protected-resource не найден на MCP-сервере" |
Google попытался выполнить обнаружение метаданных защищенных ресурсов OAuth 2.0 (RFC 9728), но произошла ошибка. |
- Если MCP-сервер НЕ требует аутентификации. Эта ошибка обычно возникает, когда в URL конечной точки MCP есть опечатка или отсутствует сегмент пути (например,
https://mcp.example.com вместо https://mcp.example.com/mcp) и возвращается HTTP 404 или 500, из-за чего клиент возвращается к обнаружению OAuth. Убедитесь, что точный путь к конечной точке MCP возвращает HTTP 200 OK для неаутентифицированных запросов POST initialize и tools/list, и выберите Нет в разделе Требуется ли авторизация на сервере? в Учетные данные для доступа.
- Если на MCP-сервере требуется аутентификация, разместите на нем действительный JSON-файл
/.well-known/oauth-protected-resource, который объявляет доверенные серверы авторизации в массиве authorization_servers.
|
Отсутствуют или недействительны метаданные сервера авторизации OAuth |
"Файл /.well-known/oauth-authorization-server не найден на сервере OAuth" или "содержит недопустимый или неполный код JSON" |
Ваш сервер OAuth не предоставляет действительный документ метаданных RFC 8414 по адресу /.well-known/oauth-authorization-server. |
- Разместите действительный discovery-документ RFC 8414 по адресу
/.well-known/oauth-authorization-server (или /.well-known/openid-configuration), содержащий authorization_endpoint и token_endpoint.
- Вы также можете вручную ввести URL в поля Собственная конечная точка авторизации и Собственная конечная точка токена в разделе Учетные данные.
|
Не удается подтвердить право собственности на домен |
В разделе Сертификат домена указано Не удалось проверить или Проверка не пройдена с сообщением в подсказке (например, HTTP 404, переадресация запрещена или несоответствие токена). |
Google не удалось проверить токен подтверждения на странице https://<domain>/.well-known/google-connected-apps. |
- Файл не найден (HTTP 404). Убедитесь, что скачанный контент
google-connected-apps.json опубликован по адресу https://<domain>/.well-known/google-connected-apps (без расширения .json в пути URL).
- Переадресация запрещена. Полезная нагрузка для подтверждения должна передаваться непосредственно с помощью
HTTP 200 OK. Не перенаправляйте /.well-known/google-connected-apps на другой URL.
- Несоответствие токена. Убедитесь, что ответ JSON содержит
"verification_tokens": ["<YOUR_TOKEN>"] с токеном, который был сгенерирован для вашего аккаунта разработчика.
|
Ошибка Dynamic Client Registration (DCR) или CIMD |
"Не удалось выполнить динамическую регистрацию клиента (RFC 7591)", "Сервер OAuth не поддерживает динамическую регистрацию клиентов (RFC 7591)" или "Не удалось зарегистрировать документ с метаданными идентификатора клиента (CIMD)" |
Автоматическая регистрация клиента OAuth не удалась или не поддерживается вашим поставщиком OAuth, или URI перенаправления Google были отклонены. |
- Убедитесь, что ваш сервер OAuth разрешает все шесть URI перенаправления Google, указанных в разделе Учетные данные для аутентификации на сервере (
https://oauth-redirect.googleusercontent.com/r/<app-id>-<sanitized-domain> и т. д.). Обратите внимание, что многие серверы OAuth 2.1 отклоняют URI перенаправления с подстановочными знаками (*).
- Если ваш поставщик OAuth не поддерживает CIMD или RFC 7591 DCR, в разделе Учетные данные для доступа выберите Предварительно зарегистрировано (для OAuth с делегированием пользователя) или Межмашинное взаимодействие (учетные данные клиента OAuth) и укажите статический идентификатор клиента и секретный код клиента.
|
Всплывающее окно входа OAuth заблокировано или пустое |
"Всплывающее окно аутентификации заблокировано браузером" или окно входа OAuth не отображается должным образом во время синхронизации или тестирования инструмента. |
Блокировщики всплывающих окон в браузере или строгие заголовки X-Frame-Options/Content-Security-Policy на странице входа не позволяют открыть всплывающее окно. |
- Разрешите всплывающие окна для консоли в браузере и повторите попытку.
- В разделе Access credentials (Учетные данные для доступа) в пункте Authenticate with your developer credentials (Аутентификация с помощью учетных данных разработчика) измените значение Authenticate via Pop up (Аутентификация с помощью всплывающего окна) на Authenticate via Redirect (fallback) (Аутентификация с помощью переадресации (резервный вариант)), чтобы аутентификация проходила в полноэкранном режиме в той же вкладке.
|
Нет инструкций для MCP-сервера |
Предупреждение: "На MCP-сервере нет инструкций. Рекомендуем добавить их в схему сервера. |
MCP-сервер не вернул поле instructions в ответе initialize. |
- Явно задайте системные инструкции при инициализации MCP-сервера (параметр
instructions в определении сервера).
- Для реализаций HTTP без отслеживания состояния или пользовательских реализаций HTTP убедитесь, что поле
instructions включено в полезную нагрузку ответа JSON-RPC для метода initialize, а затем выберите Повторно синхронизировать инструменты.
|
Превышен размер ресурса интерфейса или используется неподдерживаемый MIME-тип |
Карточка ошибки Проблемы с получением: "Общий объем ресурсов не должен превышать 100 МБ" или "Неподдерживаемый MIME-тип '<тип>' для ресурса '<uri>'". |
MCP-сервер вернул ресурсы пользовательского интерфейса, общий размер которых превышает ограничение или которые используют неподдерживаемый MIME-тип. |
- Уменьшите общий размер всех ресурсов манифеста, возвращаемых сервером, чтобы он не превышал лимит.
- Убедитесь, что все ресурсы пользовательского интерфейса используют один из поддерживаемых MIME-типов:
text/html, text/html;profile=mcp-app, text/javascript или text/css.
|
Загрузка значка зависла или произошла непредвиденная ошибка |
При загрузке значка приложения в разделе О приложении загрузка зависает на индикаторе выполнения или появляется сообщение "Произошла непредвиденная ошибка. Повторите попытку" (часто с кодом 4E696748). |
Обычно это происходит из-за устаревшего сеанса браузера, конфликтующих расширений браузера или кешированного состояния аутентификации. |
Попробуйте выполнить следующие действия по порядку:
- Используйте новый профиль браузера. Откройте новое окно, используя новый профиль браузера.
- Используйте режим инкогнито. Войдите в Google Connected Console в режиме инкогнито и загрузите значок.
- Очистите кеш. Очистите кеш и удалите файлы cookie в браузере, а затем повторите попытку. Убедитесь, что значок соответствует требованиям: формат PNG или JPEG, размер 512 x 512 пикселей, объем до 1 МБ.
|