แก้ปัญหาการลงทะเบียน

หากพบปัญหาขณะลงทะเบียนหรือกำหนดค่าแอปที่เชื่อมต่อ โปรดดูตารางข้อความแสดงข้อผิดพลาด สาเหตุ และขั้นตอนการแก้ปัญหาที่พบบ่อยต่อไปนี้

ปัญหา ข้อความแสดงข้อผิดพลาด สาเหตุ ขั้นตอนการแก้ไข/แก้ปัญหา

"เครื่องมือดึงข้อมูล" ไม่ทำงานโดยไม่ระบุสาเหตุ

"ดึงข้อมูลรายละเอียดเซิร์ฟเวอร์ MCP ไม่สำเร็จ โปรดลองอีกครั้ง" (หรือปุ่มเครื่องมือดึงข้อมูลไม่ทำงานโดยไม่มีข้อความแสดงข้อผิดพลาดที่เฉพาะเจาะจง)

Connected Console ไม่สามารถดำเนินการตามคำขอไปยังปลายทาง MCP ของคุณได้เนื่องจาก URL ไม่ถูกต้อง เซิร์ฟเวอร์ออฟไลน์ หรือข้อผิดพลาดเกี่ยวกับเครือข่าย

ตรวจสอบสิ่งต่อไปนี้

  • ตรวจสอบอีกครั้งว่า URL ปลายทาง MCP ถูกต้องและใช้ https://
  • ตรวจสอบว่าเซิร์ฟเวอร์ MCP ทำงานอยู่
  • ยืนยันว่าเซิร์ฟเวอร์ MCP ของคุณเข้าถึงได้จากอินเทอร์เน็ตสาธารณะ (Google ไม่สามารถเข้าถึง localhost หรือที่อยู่อินทราเน็ตส่วนตัว)

เข้าถึงเซิร์ฟเวอร์ MCP ไม่ได้

"เข้าถึงเซิร์ฟเวอร์ MCP ไม่ได้"

แบ็กเอนด์ของ Google สร้างการเชื่อมต่อกับปลายทาง MCP ของคุณไม่ได้

สาเหตุที่พบบ่อยและวิธีแก้ไขมีดังนี้

  • ข้อจำกัดของไฟร์วอลล์: ตรวจสอบว่าไฟร์วอลล์หรือ WAF ไม่ได้บล็อกช่วง IP ขาออกของ Google
  • กฎเกตเวย์ API: ตรวจสอบว่าเกตเวย์ API ยอมรับคำขอ POST และไม่ปฏิเสธ clientInfo ของ Google ในระหว่างแฮนด์เชค MCP initialize
  • โดเมนย่อยไม่ตรงกัน: หากคุณใช้โดเมนย่อยเฉพาะ (เช่น gemini.mcp.company.com) ให้ตรวจสอบว่าข้อมูลเมตา /.well-known/oauth-protected-resource ตรงกับโดเมนย่อยนั้น แทนที่จะชี้ไปยังโดเมนฐานอื่น (mcp.company.com)

ไม่รองรับการส่ง MCP (HTTP 405)

"เซิร์ฟเวอร์ MCP ปฏิเสธคำขอ (HTTP 405 Method Not Allowed) ตรวจสอบว่า URL ชี้ไปยังปลายทาง HTTP ที่สตรีมได้ซึ่งยอมรับคำขอ POST ไม่ใช่ปลายทาง SSE เดิม"

URL ปลายทางชี้ไปยังปลายทาง HTTP+SSE เดิมที่ยอมรับเฉพาะคำขอ GET หรือปฏิเสธคำขอ JSON-RPC POST

อัปเดตเซิร์ฟเวอร์ MCP และ URL ปลายทางเพื่อใช้การรับส่งข้อมูล HTTP ที่สตรีมได้ของ MCP ซึ่งยอมรับคำขอ POST สำหรับ initialize และ tools/list

ไม่มีไฟล์ทรัพยากรที่ได้รับการคุ้มครองของ OAuth

"ไม่มีไฟล์ /.well-known/oauth-protected-resource ในเซิร์ฟเวอร์ MCP"

Google พยายามค้นหาข้อมูลเมตาของทรัพยากรที่ได้รับการปกป้องด้วย OAuth 2.0 (RFC 9728) แต่ไม่สำเร็จ

  • หากเซิร์ฟเวอร์ MCP ไม่ต้องมีการตรวจสอบสิทธิ์: ข้อผิดพลาดนี้มักเกิดขึ้นเมื่อ URL ปลายทางของ MCP มีการพิมพ์ผิดหรือมีส่วนเส้นทางที่ขาดหายไป (เช่น https://mcp.example.com แทนที่จะเป็น https://mcp.example.com/mcp) และแสดงผลเป็น HTTP 404 หรือ 500 ซึ่งทำให้ไคลเอ็นต์กลับไปใช้การค้นพบ OAuth ตรวจสอบว่าเส้นทางปลายทาง MCP ที่แน่นอนแสดงผล HTTP 200 OK สำหรับคำขอ initialize และ tools/list ที่ไม่ได้รับการตรวจสอบสิทธิ์ POST และเลือกไม่ในส่วนเซิร์ฟเวอร์ของคุณต้องมีการให้สิทธิ์หรือไม่ในข้อมูลเข้าสู่ระบบเพื่อเข้าถึง
  • หากเซิร์ฟเวอร์ MCP ต้องมีการตรวจสอบสิทธิ์: โฮสต์ไฟล์ JSON /.well-known/oauth-protected-resource ที่ถูกต้องในเซิร์ฟเวอร์ MCP ซึ่งโฆษณาเซิร์ฟเวอร์การให้สิทธิ์ที่เชื่อถือได้ในอาร์เรย์ authorization_servers

ไม่มีข้อมูลเมตาของเซิร์ฟเวอร์การให้สิทธิ์ OAuth หรือข้อมูลเมตาไม่ถูกต้อง

"ไม่มีไฟล์ /.well-known/oauth-authorization-server ในเซิร์ฟเวอร์ OAuth" หรือ "มี JSON ที่ไม่ถูกต้องหรือไม่สมบูรณ์"

เซิร์ฟเวอร์ OAuth ของคุณไม่แสดงเอกสารข้อมูลเมตา RFC 8414 ที่ถูกต้องที่ /.well-known/oauth-authorization-server

  • โฮสต์เอกสารการค้นพบ RFC 8414 ที่ถูกต้องที่ /.well-known/oauth-authorization-server (หรือ /.well-known/openid-configuration) ซึ่งมี authorization_endpoint และ token_endpoint
  • หรือในส่วนข้อมูลเข้าสู่ระบบ ให้ป้อน URL ของปลายทางการให้สิทธิ์ที่กำหนดเองและปลายทางโทเค็นที่กำหนดเองด้วยตนเอง

การยืนยันโดเมนไม่สำเร็จ

ใบรับรองโดเมนแสดงข้อความ "ยืนยันไม่สำเร็จ" หรือ "การยืนยันไม่สำเร็จ" พร้อมข้อความเคล็ดลับเครื่องมือ (เช่น HTTP 404, ไม่อนุญาตให้เปลี่ยนเส้นทาง หรือโทเค็นไม่ตรงกัน)

Google ยืนยันโทเค็นการตรวจสอบที่ https://<domain>/.well-known/google-connected-apps ไม่ได้

  • ไม่พบไฟล์ (HTTP 404): ตรวจสอบว่าเนื้อหา google-connected-apps.json ที่ดาวน์โหลดได้รับการเผยแพร่ที่ https://<domain>/.well-known/google-connected-apps (โดยไม่มีนามสกุล .json ในเส้นทาง URL)
  • ไม่อนุญาตให้เปลี่ยนเส้นทาง: แสดงเพย์โหลดการยืนยันโดยตรงด้วย HTTP 200 OK อย่าเปลี่ยนเส้นทาง /.well-known/google-connected-apps ไปยัง URL อื่น
  • โทเค็นไม่ตรงกัน: ยืนยันว่าการตอบกลับ JSON มี "verification_tokens": ["<YOUR_TOKEN>"] พร้อมโทเค็นที่สร้างขึ้นสำหรับบัญชีนักพัฒนาแอปของคุณอย่างถูกต้อง

Dynamic Client Registration (DCR) หรือ CIMD ไม่สำเร็จ

"การจดทะเบียนไคลเอ็นต์ไดนามิก (RFC 7591) ไม่สำเร็จ", "เซิร์ฟเวอร์ OAuth ไม่รองรับการจดทะเบียนไคลเอ็นต์ไดนามิก (RFC 7591)" หรือ "ลงทะเบียนเอกสารข้อมูลเมตาของรหัสไคลเอ็นต์ (CIMD) ไม่สำเร็จ"

การลงทะเบียนไคลเอ็นต์ OAuth อัตโนมัติไม่สำเร็จหรือผู้ให้บริการ OAuth ไม่รองรับ หรือ URI การเปลี่ยนเส้นทางของ Google ถูกปฏิเสธ

  • ตรวจสอบว่าเซิร์ฟเวอร์ OAuth เพิ่ม URI การเปลี่ยนเส้นทางของ Google ทั้ง 6 รายการที่เจาะจงแอปซึ่งแสดงในส่วนข้อมูลเข้าสู่ระบบการตรวจสอบสิทธิ์เซิร์ฟเวอร์ (https://oauth-redirect.googleusercontent.com/r/<app-id>-<sanitized-domain> ฯลฯ) ลงในรายการที่อนุญาต โปรดทราบว่าเซิร์ฟเวอร์ OAuth 2.1 จำนวนมากปฏิเสธ URI การเปลี่ยนเส้นทางไวลด์การ์ด (*)
  • หากผู้ให้บริการ OAuth ไม่รองรับ CIMD หรือ RFC 7591 DCR ให้เลือกลงทะเบียนล่วงหน้า (สำหรับ OAuth ที่ผู้ใช้มอบสิทธิ์) หรือแบบ Machine-to-Machine (ข้อมูลเข้าสู่ระบบไคลเอ็นต์ OAuth) ในข้อมูลเข้าสู่ระบบเพื่อเข้าถึง แล้วระบุรหัสไคลเอ็นต์และรหัสลับไคลเอ็นต์แบบคงที่

ป๊อปอัปการเข้าสู่ระบบ OAuth ถูกบล็อกหรือว่างเปล่า

"เบราว์เซอร์บล็อกป๊อปอัปการตรวจสอบสิทธิ์" หรือหน้าต่างการเข้าสู่ระบบ OAuth แสดงไม่ถูกต้องระหว่างการซิงค์หรือการทดสอบเครื่องมือ

ตัวบล็อกป๊อปอัปของเบราว์เซอร์หรือส่วนหัว X-Frame-Options / Content-Security-Policy ที่เข้มงวดในหน้าเข้าสู่ระบบทำให้ขั้นตอนป๊อปอัปไม่ทำงาน

  • โปรดอนุญาตป๊อปอัปสำหรับคอนโซลในเบราว์เซอร์แล้วลองอีกครั้ง
  • ในข้อมูลเข้าสู่ระบบเพื่อเข้าถึงในส่วนตรวจสอบสิทธิ์ด้วยข้อมูลเข้าสู่ระบบของนักพัฒนาแอป ให้เปลี่ยนจากตรวจสอบสิทธิ์ผ่านป๊อปอัปเป็นตรวจสอบสิทธิ์ผ่านการเปลี่ยนเส้นทาง (สำรอง) เพื่อให้ขั้นตอนการตรวจสอบสิทธิ์เปิดแบบเต็มหน้าจอในแท็บเดียวกัน

ไม่มีคำสั่งเซิร์ฟเวอร์ MCP

ข้อความเตือน: "เซิร์ฟเวอร์ MCP ของคุณไม่มีวิธีการ เราขอแนะนำให้เพิ่มวิธีการลงในสคีมาเซิร์ฟเวอร์"

เซิร์ฟเวอร์ MCP ของคุณไม่ได้แสดงผลช่อง instructions ในการตอบกลับ initialize

  • กำหนดคำสั่งของระบบอย่างชัดเจนเมื่อเริ่มต้นเซิร์ฟเวอร์ MCP (พารามิเตอร์ instructions ในคำจำกัดความของเซิร์ฟเวอร์)
  • สำหรับการใช้งาน HTTP แบบไม่เก็บสถานะหรือแบบกำหนดเอง ให้ตรวจสอบว่าได้รวมช่อง instructions ไว้ในเพย์โหลดการตอบกลับ JSON-RPC สำหรับเมธอด initialize แล้ว จากนั้นเลือกซิงค์เครื่องมืออีกครั้ง

ขนาดทรัพยากร UI เกินขีดจำกัดหรือประเภท MIME ไม่รองรับ

การ์ดข้อผิดพลาดปัญหาเกี่ยวกับการดึงข้อมูล: "ขนาดทรัพยากรสะสมต้องไม่เกิน 100 MB" หรือ "ประเภท MIME '<type>' ที่ไม่รองรับสำหรับทรัพยากร '<uri>'"

เซิร์ฟเวอร์ MCP แสดงผลทรัพยากร UI ที่มีขนาดรวมเกินขีดจำกัดหรือใช้ประเภท MIME ที่ไม่รองรับ

  • ลดขนาดสะสมของทรัพยากร UI ของไฟล์ Manifest ทั้งหมดที่เซิร์ฟเวอร์แสดงผลเพื่อไม่ให้เกินขีดจำกัด
  • ตรวจสอบว่าทรัพยากร UI ทั้งหมดใช้ประเภท MIME ที่รองรับอย่างใดอย่างหนึ่งต่อไปนี้ text/html, text/html;profile=mcp-app, text/javascript หรือ text/css

การอัปโหลดไอคอนค้างหรือ "ข้อผิดพลาดที่ไม่คาดคิด"

เมื่ออัปโหลดไอคอนแอปในรายละเอียดแอป การอัปโหลดค้างอยู่ที่ไอคอนหมุนเพื่อโหลดหรือแสดงข้อความ "เกิดข้อผิดพลาดที่ไม่คาดคิด โปรดลองอีกครั้ง" (มักมาพร้อมกับรหัส 4E696748)

โดยปกติแล้วจะเกิดจากเซสชันเบราว์เซอร์ที่ไม่มีการใช้งาน ส่วนขยายเบราว์เซอร์ที่ขัดแย้งกัน หรือสถานะการตรวจสอบสิทธิ์ที่แคชไว้

ลองทำตามขั้นตอนต่อไปนี้ตามลำดับ

  1. ใช้โปรไฟล์เบราว์เซอร์ใหม่: เปิดหน้าต่างใหม่โดยใช้โปรไฟล์เบราว์เซอร์ที่ไม่มีข้อมูลใดๆ
  2. ใช้โหมดไม่ระบุตัวตน/ส่วนตัว: ลงชื่อเข้าใช้ Google Connected Console ในหน้าต่างการท่องเว็บแบบส่วนตัว แล้วอัปโหลดไอคอน
  3. ล้างแคช: ล้างแคชและคุกกี้ของเบราว์เซอร์ก่อนลองอีกครั้ง และตรวจสอบว่าไอคอนเป็นไฟล์ PNG หรือ JPEG ขนาด 512 พิกเซล × 512 พิกเซลที่ถูกต้องและมีขนาดไม่เกิน 1 MB