# Resources

Refer to the following documents as needed:

- [RFC 1738](http://www.ietf.org/rfc/rfc1738.txt): Uniform Resource Locators(URL).
- [RFC 2119](http://www.ietf.org/rfc/rfc2119.txt): Keywords for use in RFCs.
- [RFC 2396](http://www.ietf.org/rfc/rfc2396.txt): Uniform Resource Identifiers (URI): Generic Syntax.
- [RFC 2616](http://www.ietf.org/rfc/rfc2616.txt): Hypertext transfer Protocol HTTP/1.1.
- [RFC 3629](http://www.ietf.org/rfc/rfc3629.txt): UTF-8.
- [RFC 3986](http://www.ietf.org/rfc/rfc3986.txt): Uniform Resource Indentifier(URI).
- [FIPS-180-2](http://csrc.nist.gov/publications/fips/fips180-2/fips180-2withchangenotice.pdf): SHA 256.
- [Mozilla/Firefox Phishing Protection](http://wiki.mozilla.org/Phishing_Protection): Guides and references.
- [Google Protocol Buffers](https://developers.google.com/protocol-buffers/): Guides and references.