安裝用戶端程式庫

Indexing API 是以 HTTP 和 JSON 為基礎建置,所以所有標準 HTTP 用戶端都可以向 Indexing API 傳送要求並剖析回應。

然而,Google API 用戶端程式庫可提供更好的語言整合、加強安全性並支援需要使用者授權的呼叫功能。用戶端程式庫支援多種程式語言,只要善加利用,您就不必再手動設定 HTTP 要求及剖析回應。

首先,請選擇要用於開發作業的程式語言。

Go

取得適用於 Go 的 Indexing API 用戶端程式庫 (Alpha 版) 最新版本。

閱讀用戶端程式庫的開發人員指南

Java

本頁面會說明如何透過適用於 Java 的 Google API 用戶端程式庫開始使用 Indexing API。此外,您可能也想閱讀以下說明文件:

將程式庫新增到您的專案

從下列分頁選取您的建構環境 (Maven 或 Gradle),或是下載包含所有您所需 Jar 的 ZIP 檔案:

下載

下載適用於 Java 的 Indexing API v3 用戶端程式庫

參閱 indexing/readme.html 檔案以瞭解下方資訊:

  • Zip 檔案包含的內容。
  • 每種應用程式類型 (網路應用程式、已安裝應用程式或 Android 應用程式) 需要哪些相依的 Jar。

libs 資料夾包含所有應用程式類型可能需要的全域適用依附元件。

JavaScript

閱讀用戶端程式庫的開發人員指南

.NET

本頁面會說明如何透過適用於 .NET 的 Google API 用戶端程式庫開始使用 Indexing API。此外,您可能也想閱讀以下說明文件:

下載程式庫

安裝 NuGet 套件: Google.Apis

Node.js

取得適用於 Node.js 的 Indexing API 用戶端程式庫最新版本。

閱讀用戶端程式庫的開發人員指南

Obj-C

取得適用於 Objective-C 的 Indexing API 用戶端程式庫最新版本。

閱讀用戶端程式庫的開發人員指南

PHP

取得適用於 PHP 的 Indexing API 用戶端程式庫 (Beta 版) 最新版本。

閱讀用戶端程式庫的開發人員指南

Python

本頁面會說明如何透過適用於 Python 的 Google API 用戶端程式庫開始使用 Indexing API。此外,您可能也想閱讀以下說明文件:

系統需求

安裝用戶端程式庫

您可以使用套件管理員或是手動下載並安裝 Python 用戶端程式庫:

代管安裝

使用 pip 或 setuptools 管理安裝作業 (您可能必須先執行 sudo):

  • pip (建議選項):
    $ pip install --upgrade google-api-python-client
  • setuptools:使用 setuptools 套件中的 easy_install 工具:
    $ easy_install --upgrade google-api-python-client

手動安裝

下載最新版 Python 用戶端程式庫,解壓縮程式碼,然後執行 python setup.py install

App Engine

App Engine Python 執行階段環境並未安裝 Python 用戶端程式庫,因此您必須將這類程式庫加入您的應用程式,方法與加入第三方用戶端程式庫相同。

Ruby

本頁面會說明如何透過適用於 Ruby 的 Google API 用戶端程式庫開始使用 Indexing API。此外,您可能也想閱讀以下說明文件:

安裝 google-api-client gem

如果您尚未安裝適用於 Ruby 的 Google API 用戶端程式庫,請開啟終端機並使用 RubyGems 開始安裝:

$ gem install google-api-client

假如您已安裝 gem,並且只想更新至最新版本:

$ gem update -y google-api-client

視您的系統而定,您可能必須在這些指令前加上 sudo

開始使用適用於 Ruby 的 Google API 用戶端程式庫

請務必查看我們完善的入門指南,快速瞭解如何提出第一個要求。

其他存取 Indexing API 的方法

下表列出了其他存取 Indexing API 的便利方法。

存取方法 說明
APIs Explorer 這項互動式工具可讓您直接在瀏覽器中輕鬆試用 Google API。

傳送您對下列選項的寶貴意見...

這個網頁