注意:此开发者网站正在向 developers.google.com/tag-platform 迁移,2021 年 9 月 30 日起系统会将您重定向到新的网址

Container Versions:get

需要授权

获取容器版本。 立即试用查看示例

请求

HTTP 请求

GET https://www.googleapis.com/tagmanager/v1/accounts/accountId/containers/containerId/versions/containerVersionId

参数

参数名称 说明
路径参数
accountId string GTM 帐号 ID。
containerId string GTM 容器 ID。
containerVersionId string GTM 容器版本 ID。指定为 published 时,会检索当前发布的版本。

授权

此请求至少需要获得以下任一范围的授权(详细了解身份验证和授权)。

范围
https://www.googleapis.com/auth/tagmanager.readonly
https://www.googleapis.com/auth/tagmanager.edit.containerversions
https://www.googleapis.com/auth/tagmanager.edit.containers

请求正文

请勿使用此方法提供请求正文。

响应

如果成功,此方法会在响应正文中返回 Container Versions 资源

示例

注意:此方法的代码示例并未列出所有受支持的编程语言(请参阅客户端库页面,查看受支持的语言列表)。

Java

使用 Java 客户端库

/*
 * Note: This code assumes you have an authorized tagmanager service object.
 */

/*
 * This request gets an existing container version.
 */
try {
  ContainerVersion version = tagmanager.accounts().containers().
      versions().get("123456", "54321", "2").execute();
} catch (GoogleJsonResponseException e) {
  System.err.println("There was a service error: "
      + e.getDetails().getCode() + " : "
      + e.getDetails().getMessage());
}

Python

使用 Python 客户端库

# Note: This code assumes you have an authorized tagmanager service object.

# This request gets an existing container version.
try:
  version = tagmanager.accounts().containers().versions().get(
      accountId='123456',
      containerId='54321',
      containerVersionId='2'
  ).execute()

except TypeError, error:
  # Handle errors in constructing a query.
  print 'There was an error in constructing your query : %s' % error

except HttpError, error:
  # Handle API errors.
  print ('There was an API error : %s : %s' %
         (error.resp.status, error.resp.reason))

试用一下!

请使用下面的 API Explorer 针对实际数据调用此方法,并查看响应。