פתרון בעיות ברישום

אם נתקלתם בבעיות במהלך הרישום או ההגדרה של האפליקציה המקושרת, אתם יכולים להיעזר בטבלה הבאה שכוללת הודעות שגיאה נפוצות, סיבות ושלבים לפתרון בעיות.

בעיה הודעת השגיאה הסיבה שלבים לפתרון הבעיה

כשל לא מוגדר ב "כלי אחזור"

"הייתה בעיה ופרטי שרת ה-MCP לא אוחזרו. אפשר לנסות שוב." (או שהלחצן אחזור כלים נכשל בלי הודעת שגיאה ספציפית).

‫Connected Console לא הצליח להשלים את הבקשה לנקודת הקצה של ה-MCP בגלל כתובת URL לא תקינה, שרת אופליין או שגיאה בחיבור לרשת.

בודקים את הדברים הבאים:

  • חשוב לוודא שכתובת ה-URL של נקודת הקצה של ה-MCP מדויקת ומשתמשת ב-https://.
  • מוודאים ששרת ה-MCP פועל.
  • צריך לוודא שאפשר לגשת לשרת ה-MCP מהאינטרנט הציבורי (ל-Google אין גישה ל-localhost או לכתובות אינטראנט פרטיות).

אין גישה לשרת ה-MCP

"אין גישה לשרת ה-MCP"

ה-backend של Google לא הצליח ליצור חיבור לנקודת הקצה של ה-MCP.

סיבות נפוצות ופתרונות:

  • הגבלות של חומת אש: ודאו שחומת האש או ה-WAF לא חוסמים את טווחי כתובות ה-IP היוצאות של Google.
  • כללי שער ה-API: מוודאים ששער ה-API מקבל בקשות POST ולא דוחה את clientInfo של Google במהלך לחיצת היד של initialize ב-MCP.
  • חוסר התאמה בתת-הדומיין: אם אתם משתמשים בתת-דומיין ייעודי (כמו gemini.mcp.company.com), ודאו שהמטא-נתונים של /.well-known/oauth-protected-resource תואמים לתת-הדומיין הזה ולא מפנים לדומיין בסיס אחר (mcp.company.com).

תעבורת MCP לא נתמכת (HTTP 405)

"שרת ה-MCP דחה את הבקשה (HTTP 405 Method Not Allowed). צריך לוודא שכתובת ה-URL מפנה לנקודת קצה שתומכת בסטרימינג של נתוני HTTP ומקבלת בקשות POST, ולא לנקודת קצה SSE מדור קודם."

כתובת ה-URL של נקודת הקצה מפנה לנקודת קצה מדור קודם של HTTP+SSE שמקבלת רק בקשות GET או דוחה בקשות JSON-RPC POST.

מעדכנים את שרת ה-MCP ואת כתובת ה-URL של נקודת הקצה כך שישתמשו ב-MCP Streamable HTTP transport שמקבל בקשות POST עבור initialize ו-tools/list.

חסר קובץ משאב מוגן של OAuth

"הקובץ /.well-known/oauth-protected-resource לא קיים בשרת ה-MCP"

‫Google ניסתה לבצע גילוי של מטא-נתונים של משאבים מוגנים ב-OAuth 2.0‏ (RFC 9728), אבל הניסיון נכשל.

  • אם שרת ה-MCP לא דורש אימות: השגיאה הזו בדרך כלל מתרחשת כשיש שגיאת הקלדה בכתובת ה-URL של נקודת הקצה של ה-MCP או כשחסר חלק בנתיב (לדוגמה, https://mcp.example.com במקום https://mcp.example.com/mcp) והיא מחזירה את השגיאה HTTP 404 או 500, מה שגורם ללקוח לחזור לזיהוי OAuth. מוודאים שנתיב נקודת הקצה המדויק של ה-MCP מחזיר HTTP 200 OK לבקשות POST,‏ initialize ו-tools/list לא מאומתות, ובוחרים באפשרות לא בקטע האם השרת דורש הרשאה? בפרטי כניסה.
  • אם שרת ה-MCP דורש אימות: מארחים קובץ JSON תקין של /.well-known/oauth-protected-resource בשרת ה-MCP שמפרסם את שרתי ההרשאות המהימנים במערך authorization_servers.

מטא-נתונים חסרים או לא תקינים של שרת ההרשאות ב-OAuth

"הקובץ /.well-known/oauth-authorization-server לא קיים בשרת ה-OAuth" או "מכיל קובץ JSON לא תקין או חלקי"

שרת ה-OAuth לא חושף מסמך מטא-נתונים חוקי של RFC 8414 בכתובת /.well-known/oauth-authorization-server.

  • צריך לארח מסמך Discovery תקין מסוג RFC 8414 בכתובת /.well-known/oauth-authorization-server (או /.well-known/openid-configuration) שמכיל את authorization_endpoint ואת token_endpoint.
  • לחלופין, בקטע Credentials, מזינים באופן ידני את כתובות ה-URL של Custom authorization endpoint ו-Custom token endpoint.

אימות הדומיין נכשל

באישור הדומיין מוצגת ההודעה "האימות נכשל" או "האימות נכשל" עם הודעת הסבר קצר (כמו HTTP 404, הפניה אוטומטית אסורה או חוסר התאמה של טוקן).

‫Google לא הצליחה לאמת את אסימון האתגר שלך בכתובת https://<domain>/.well-known/google-connected-apps.

  • הקובץ לא נמצא (HTTP 404): ודאו שתוכן ה-google-connected-apps.json שהורדתם פורסם ב-https://<domain>/.well-known/google-connected-apps (בלי סיומת .json בנתיב כתובת ה-URL).
  • הפניות אוטומטיות אסורות: צריך להציג את המטען הייעודי (payload) של האימות ישירות באמצעות HTTP 200 OK. אין להפנות את /.well-known/google-connected-apps לכתובת URL אחרת.
  • חוסר התאמה של הטוקן: ודאו שתגובת ה-JSON מכילה את "verification_tokens": ["<YOUR_TOKEN>"] עם הטוקן המדויק שנוצר לחשבון הפיתוח שלכם.

כשל ב-Dynamic Client Registration‏ (DCR) או ב-CIMD

"Dynamic Client Registration (RFC 7591) נכשל", "שרת ה-OAuth לא תומך ב-Dynamic Client Registration (RFC 7591)" או "הרישום של מסמך המטא-נתונים של מזהה הלקוח (CIMD) נכשל"

הרישום האוטומטי של לקוח OAuth נכשל או לא נתמך על ידי ספק ה-OAuth, או שכתובות ה-URI להפניה אוטומטית של Google נדחו.

  • מוודאים ששרת ה-OAuth מוסיף לרשימת ההיתרים את כל שש כתובות ה-URI להפניה אוטומטית של Google שספציפיות לאפליקציה, שמופיעות בקטע פרטי כניסה לאימות של השרת (https://oauth-redirect.googleusercontent.com/r/<app-id>-<sanitized-domain> וכו'). חשוב לדעת שהרבה שרתי OAuth 2.1 דוחים כתובות URI להפניה אוטומטית עם תו כללי לחיפוש (*).
  • אם ספק ה-OAuth לא תומך ב-CIMD או ב-RFC 7591 DCR, בוחרים באפשרות רשום מראש (ל-OAuth עם הקצאת הרשאות למשתמשים) או באפשרות מכונה למכונה (פרטי כניסה של לקוח OAuth) בקטע פרטי כניסה, ומספקים מזהה לקוח וסוד לקוח סטטיים.

החלון הקופץ של ההתחברות באמצעות OAuth חסום או ריק

"הדפדפן חסם את החלון הקופץ לאימות" או שחלון ההתחברות של OAuth לא מוצג כמו שצריך במהלך סנכרון או בדיקה של הכלי.

תוכנת חסימה לחלונות קופצים בדפדפן או כותרות X-Frame-Options / Content-Security-Policy מחמירות בדף ההתחברות מנעו את תהליך החלון הקופץ.

  • מאשרים חלונות קופצים למסוף בדפדפן ומנסים שוב.
  • בקטע פרטי כניסה, מתחת לאפשרות אימות באמצעות פרטי הכניסה של המפַתח, מחליפים את האפשרות אימות באמצעות חלון קופץ באפשרות אימות באמצעות הפניה אוטומטית (חלופה) כדי שתהליך האימות ייפתח במסך מלא באותה כרטיסייה.

חסרות הוראות לשרת ה-MCP

הודעת אזהרה: "לשרת ה-MCP אין הוראות. מומלץ להוסיף הוראות לסכימת השרת".

שרת ה-MCP לא החזיר שדה instructions בתגובת initialize שלו.

  • הגדירו באופן מפורש את הוראות המערכת כשאתם מפעילים את שרת ה-MCP (הפרמטר instructions בהגדרת השרת).
  • בהטמעות HTTP בלי שמירת מצב או בהטמעות HTTP בהתאמה אישית, צריך לוודא שהשדה instructions נכלל במטען הייעודי (payload) של התגובה ל-JSON-RPC ל-method‏ initialize, ואז לבחור באפשרות סנכרון מחדש של הכלים.

מגבלת הגודל של משאב ממשק המשתמש או סוג MIME לא נתמך

כרטיס השגיאה בעיות באחזור: "הגודל המצטבר של המשאבים לא יכול להיות יותר מ-100MB" או "סוג MIME לא נתמך '<type>' במשאב '<uri>'"

שרת ה-MCP שלך החזיר משאבי ממשק משתמש שהגודל הכולל שלהם חורג מהמגבלה או שהם משתמשים בסוג MIME שלא נתמך.

  • צריך להקטין את הגודל המצטבר של כל משאבי ממשק המשתמש של המניפסט שהשרת מחזיר, כדי שלא יחרוג מהמגבלה.
  • צריך לוודא שכל משאבי ממשק המשתמש משתמשים באחד מסוגי ה-MIME הנתמכים: text/html,‏ text/html;profile=mcp-app,‏ text/javascript או text/css.

העלאת הסמל נתקעה או שמוצגת ההודעה "שגיאה לא צפויה"

כשמעלים סמל האפליקציה בפרטי האפליקציה, ההעלאה נתקעת על סימן גרפי שפעולה מתבצעת או שמוצגת ההודעה "אירעה שגיאה לא צפויה. צריך לנסות שוב" (לרוב עם הקוד 4E696748).

בדרך כלל זה קורה בגלל סשן דפדפן לא עדכני, תוספים מתנגשים בדפדפן או מצב אימות שנשמר במטמון.

נסו את הפעולות הבאות לפי הסדר:

  1. שימוש בפרופיל דפדפן חדש: פותחים חלון חדש באמצעות פרופיל דפדפן נקי.
  2. להשתמש במצב פרטי: נכנסים ל-Google Connected Console בחלון גלישה פרטית ומעלים את הסמל.
  3. ניקוי המטמון: נקו את המטמון וקובצי ה-Cookie בדפדפן לפני שתנסו שוב, וודאו שהסמל הוא קובץ PNG או JPEG תקין בגודל ‎512 x 512 פיקסלים ובנפח של פחות מ-1MB.