Клиентские библиотеки

API миграции групп основан на HTTP и JSON, поэтому любой стандартный HTTP-клиент может отправлять ему запросы и анализировать ответы.

Однако клиентские библиотеки Google API обеспечивают лучшую языковую интеграцию, повышенную безопасность и поддержку вызовов, требующих авторизации пользователя. Клиентские библиотеки доступны на нескольких языках программирования; используя их, вы можете избежать необходимости вручную настраивать HTTP-запросы и анализировать ответы.

Для начала выберите язык программирования, который вы используете для разработки.

Идти

Получите последнюю версию клиентской библиотеки Groups Migration API для Go (альфа-версия) . Прочтите руководство разработчика клиентской библиотеки.

Ява

На этой странице содержится информация о том, как начать работу с Groups Migration API с помощью клиентской библиотеки Google API для Java. Дополнительные сведения см. в следующей документации:

Добавьте клиентскую библиотеку в свой проект

Выберите среду сборки (Maven или Gradle) на следующих вкладках:

JavaScript

Прочтите руководство разработчика клиентской библиотеки.

.СЕТЬ

На этой странице содержится информация о том, как начать работу с Groups Migration API с помощью клиентской библиотеки Google API для .NET. Дополнительные сведения см. в следующей документации:

Загрузка библиотеки

Установите пакет NuGet: Google.Apis .

Node.js

Получите последнюю версию клиентской библиотеки Groups Migration API для Node.js. Прочтите руководство разработчика клиентской библиотеки.

Объект-C

Получите последнюю версию клиентской библиотеки Groups Migration API для Objective-C . Прочтите руководство разработчика клиентской библиотеки.

PHP

Получите последнюю версию клиентской библиотеки Groups Migration API для PHP (бета-версия) . Прочтите руководство разработчика клиентской библиотеки.

питон

На этой странице содержится информация о том, как начать работу с Groups Migration API с помощью клиентской библиотеки Google API для Python. Дополнительные сведения см. в следующей документации:

Системные Требования

Установите клиентскую библиотеку

Вы можете либо использовать менеджер пакетов, либо вручную загрузить и установить клиентскую библиотеку Python:

Управляемая установка

Используйте pip или setuptools для управления вашей установкой. Возможно, вам придется сначала запустить sudo .

Ручная установка

  1. Загрузите последнюю версию клиентской библиотеки для Python .
  2. Распаковать код.
  3. Установить:
    python setup.py install

Механизм приложений

Поскольку клиентские библиотеки Python не установлены в среде выполнения App Engine Python , их необходимо скопировать в приложение , как и сторонние библиотеки.

Рубин

На этой странице содержится информация о том, как начать работу с Groups Migration API с помощью клиентской библиотеки Google API для Ruby. Дополнительные сведения см. в следующей документации:

Установите гем google-api-client

В зависимости от вашей системы вам может потребоваться добавить перед этими командами sudo .

Если вы еще не устанавливали клиентскую библиотеку Google API для Ruby, установите ее с помощью RubyGems :

gem install google-api-client

Если у вас уже установлен гем, обновите его до последней версии:

gem update -y google-api-client
.

Начните работу с клиентской библиотекой Google API для Ruby

Чтобы узнать, как сделать свой первый запрос, см. руководство по началу работы.

Другие способы доступа к API миграции групп

В следующей таблице перечислены другие способы доступа к API миграции групп:

Метод доступа Описание
Проводник API Интерактивный инструмент, позволяющий опробовать API Google прямо из браузера.