ไลบรารีของไคลเอ็นต์

Google Workspace Groups Migration API สร้างขึ้นบน HTTP และ JSON ไคลเอ็นต์ HTTP มาตรฐานต่างๆ จึงส่งคําขอไปยัง API นี้และแยกวิเคราะห์การตอบกลับได้

อย่างไรก็ตาม ไลบรารีของไคลเอ็นต์ Google API มีการผสานรวมภาษาที่ดีกว่า ความปลอดภัยที่ดียิ่งขึ้น และการรองรับการเรียกที่ต้องมีการให้สิทธิ์ผู้ใช้ ไลบรารีของไคลเอ็นต์พร้อมให้บริการเป็นภาษาโปรแกรมต่างๆ เมื่อใช้งานไลบรารีเหล่านี้ คุณจะไม่ต้องตั้งค่าคำขอ HTTP และแยกวิเคราะห์การตอบกลับด้วยตนเอง

เลือกภาษาโปรแกรมที่คุณใช้ในการพัฒนาซอฟต์แวร์เพื่อเริ่มต้นใช้งาน

Go

ดูไลบรารีของไคลเอ็นต์ Google Workspace Groups Migration API ล่าสุดสําหรับ Go (อัลฟ่า) อ่านคู่มือสำหรับนักพัฒนาซอฟต์แวร์เกี่ยวกับไลบรารีของไคลเอ็นต์

Java

หน้านี้มีข้อมูลเกี่ยวกับการเริ่มต้นใช้งาน Groups Migration API โดยใช้ไลบรารีของไคลเอ็นต์ Google API สําหรับ Java สําหรับข้อมูลเพิ่มเติม โปรดดูเอกสารประกอบต่อไปนี้

เพิ่มไลบรารีของไคลเอ็นต์ลงในโปรเจ็กต์

เลือกสภาพแวดล้อมของบิลด์ (Maven หรือ Gradle) จากแท็บต่อไปนี้

JavaScript

อ่านคู่มือสำหรับนักพัฒนาซอฟต์แวร์เกี่ยวกับไลบรารีของไคลเอ็นต์

.NET

หน้านี้มีข้อมูลเกี่ยวกับการเริ่มต้นใช้งาน Groups Migration API โดยใช้ไลบรารีของไคลเอ็นต์ Google API สําหรับ .NET โปรดดูข้อมูลเพิ่มเติมในเอกสารประกอบต่อไปนี้

การดาวน์โหลดไลบรารี

ติดตั้งแพ็กเกจ NuGet นี้ Google.Apis

Node.js

ดูไลบรารีของไคลเอ็นต์ Google Workspace Groups Migration API ล่าสุดสําหรับ Node.js อ่านคู่มือสำหรับนักพัฒนาซอฟต์แวร์เกี่ยวกับไลบรารีของไคลเอ็นต์

Obj-C

ดูไลบรารีของไคลเอ็นต์ Google Workspace Groups Migration API ล่าสุดสําหรับ Objective-C อ่านคู่มือสำหรับนักพัฒนาซอฟต์แวร์เกี่ยวกับไลบรารีของไคลเอ็นต์

PHP

ดูไลบรารีของไคลเอ็นต์ Google Workspace Groups Migration API ล่าสุดสําหรับ PHP (เบต้า) อ่านคู่มือสำหรับนักพัฒนาซอฟต์แวร์เกี่ยวกับไลบรารีของไคลเอ็นต์

Python

หน้านี้มีข้อมูลเกี่ยวกับการเริ่มต้นใช้งาน Groups Migration API โดยใช้ไลบรารีของไคลเอ็นต์ Google API สําหรับ Python สําหรับข้อมูลเพิ่มเติม โปรดดูเอกสารประกอบต่อไปนี้

ข้อกำหนดของระบบ

ติดตั้งไลบรารีของไคลเอ็นต์

คุณจะใช้ตัวจัดการแพ็กเกจหรือดาวน์โหลดและติดตั้งไลบรารีของไคลเอ็นต์ Python ด้วยตนเองก็ได้โดยทำดังนี้

การติดตั้งที่มีการจัดการ

ใช้ pip หรือ setuptools เพื่อจัดการการติดตั้ง คุณอาจต้องเรียกใช้ sudo ก่อน

ติดตั้งด้วยตัวเอง

  1. ดาวน์โหลดไลบรารีของไคลเอ็นต์ล่าสุดสำหรับ Python
  2. คลายการแพคข้อมูลรหัส
  3. ติดตั้ง:
    python setup.py install

App Engine

เนื่องจากไม่มีการติดตั้งไลบรารีของไคลเอ็นต์ Python ในสภาพแวดล้อมรันไทม์ของ Python สําหรับ App Engine คุณจึงต้องคัดลอกไลบรารีเหล่านี้ลงในแอปพลิเคชันเช่นเดียวกับไลบรารีของบุคคลที่สาม

Ruby

หน้านี้มีข้อมูลเกี่ยวกับการเริ่มต้นใช้งาน Groups Migration API โดยใช้ไลบรารีของไคลเอ็นต์ Google API สําหรับ Ruby สําหรับข้อมูลเพิ่มเติม โปรดดูเอกสารประกอบต่อไปนี้

ติดตั้ง Gem google-api-client

อาจต้องเพิ่ม sudo ไว้หน้าคําสั่งเหล่านี้ ทั้งนี้ขึ้นอยู่กับระบบของคุณ

หากคุณยังไม่เคยติดตั้งไลบรารีของไคลเอ็นต์ Google API สําหรับ Ruby มาก่อน ให้ติดตั้งโดยใช้ RubyGems ดังนี้

gem install google-api-client

หากติดตั้ง gem แล้ว ให้อัปเดตเป็นเวอร์ชันล่าสุด

gem update -y google-api-client

การเริ่มต้นใช้งานไลบรารีของไคลเอ็นต์ Google API สำหรับ Ruby

ดูวิธีส่งคำขอแรกได้ที่คู่มือเริ่มต้นใช้งาน

วิธีอื่นๆ ในการเข้าถึง Google Workspace Groups Migration API

ตารางต่อไปนี้แสดงวิธีอื่นๆ ในการเข้าถึง Google Workspace Groups Migration API

วิธีการเข้าถึง คำอธิบาย
โปรแกรมสำรวจ APIs เครื่องมืออินเทอร์แอกทีฟที่ให้คุณลองใช้ Google APIs ได้จากเบราว์เซอร์ของคุณ