Biblioteca de cliente PHP

A biblioteca de cliente de PHP está hospedada em https://github.com/googleads/google-ads-php e também está disponível por meio de sistemas de gerenciamento de dependências:

Verifique a versão mínima do PHP compatível com essa biblioteca em composer.json. A versão é especificada como um valor de php da chave require. A biblioteca segue a programação de desativação do PHP e atualiza o arquivo composer.json de quatro a cinco meses depois que a versão mínima necessária do PHP atinge o fim da vida útil. Com base nas versões do PHP compatíveis atualmente, a atualização ocorre cerca de uma vez por ano.

Conforme indicado em composer.json, a biblioteca depende de gRPC e tem outros pré-requisitos. Consulte também Introdução e Uso básico antes de usar esta biblioteca.

Para configurar a biblioteca de cliente com OAuth, consulte estes guias:

Confira os seguintes guias sobre os recursos e utilitários da biblioteca: