Opis

Biblioteka klienta Pythona jest hostowana w serwisie GitHub, a pakiet jest dostępny w języku PyPI.

W wersji 10.0.0 biblioteki klienta wprowadziliśmy szereg zmian w interfejsie, które opisaliśmy w sekcji Library w wersji 10.0.0.

Wymagania

Biblioteka wymaga Pythona w wersji 3.7 lub nowszej. Zgodność z Pythonem 2 została wycofana w wersji 4.0.0 biblioteki. Więcej informacji znajdziesz w tym poście na blogu.

Wymagania wstępne

Zanim zainstalujesz bibliotekę, potrzebujesz tokena programisty i identyfikatora klienta klienta. Instrukcje ich uzyskiwania znajdziesz w sekcji wymagań wstępnych. Inne wymagane tokeny OAuth2 trzeba wygenerować w dalszych krokach.

Montaż

Wykonaj instrukcje podane w naszej dokumentacji instalacji, by zainstalować bibliotekę z PyPi i wrócić na tę stronę.

Konfiguracja

Po zainstalowaniu biblioteki musisz skonfigurować dla niej konfigurację. Biblioteka jest dostępna na wiele sposobów. Opisaliśmy je w dokumentacji konfiguracji.

Uwierzytelnianie

Po wybraniu typu konfiguracji możesz wygenerować pozostałe tokeny OAuth2 niezbędne do wysyłania żądań do interfejsu API. Istnieje kilka obsługiwanych przepływów OAuth2, które zostały udokumentowane na liście poniżej. Szczegółowe informacje o różnicach między tymi procesami znajdziesz w dokumentacji dotyczącej protokołu OAuth.

Wysyłanie żądania do interfejsu API

Po zintegrowaniu tokenów OAuth2 w konfiguracji możesz wysłać żądanie do interfejsu API. Zapoznaj się z przykładem pobierania kampanii, by zobaczyć, jak w prosty sposób sprawdzić, czy biblioteka jest prawidłowo skonfigurowana pod kątem żądań interfejsu API.

Dodatkowe materiały

Gdy będziesz mieć możliwość wysłania żądania do interfejsu API, przejdź do następujących sposobów wykorzystania biblioteki klienta: