Ringkasan

Library klien Python dihosting di GitHub, dan paketnya tersedia di PyPI.

Library klien versi 10.0.0 memperkenalkan sejumlah perubahan antarmuka yang telah kami dokumentasikan di bagian Library versi 10.0.0.

Persyaratan

Library memerlukan Python 3.7 atau yang lebih baru. Perlu diperhatikan bahwa kompatibilitas dengan Python 2 tidak digunakan lagi dalam library versi 4.0.0. Untuk informasi lebih lanjut, lihat postingan blog ini.

Prasyarat

Sebelum menginstal library, Anda memerlukan token developer dan client ID klien. Petunjuk tentang cara mendapatkannya diuraikan di bagian prasyarat. Perhatikan bahwa Anda akan membuat token OAuth2 lain yang diperlukan di langkah berikutnya.

Penginstalan

Ikuti petunjuk dalam dokumentasi penginstalan kami untuk menginstal library dari PyPi dan kembali ke halaman ini.

Konfigurasi

Setelah menginstal library, Anda harus menyiapkan konfigurasi untuk library tersebut. Ada beberapa cara untuk mengonfigurasi library, yang dijelaskan dalam dokumentasi konfigurasi kami.

Autentikasi

Setelah memilih jenis konfigurasi, Anda dapat melanjutkan untuk membuat token OAuth2 yang tersisa yang diperlukan untuk membuat permintaan ke API. Ada beberapa alur OAuth2 yang didukung, yang didokumentasikan dalam daftar di bawah ini. Untuk mengetahui detail tentang perbedaan antara alur dan membantu memutuskan yang terbaik untuk aplikasi Anda, lihat dokumentasi OAuth.

Membuat permintaan API

Setelah memasukkan token OAuth2 ke dalam konfigurasi, Anda siap membuat permintaan API. Lihat contoh dapatkan kampanye untuk cara mudah menguji apakah library dikonfigurasi dengan benar untuk membuat permintaan API.

Referensi tambahan

Setelah Anda dapat membuat permintaan API, lanjutkan ke penggunaan library klien ini: